nodejs升级导致gulp不能用了

在写node多页应用的时候,升级了nodejs;

过了会,回到另外一个项目,需要用gulp的时候,任务列表挂了;

QQ图片20171010103144

at Object.<anonymous> (F:\xxxxxxx\node_modules\gulp-scp2\node_modules\scp2\node_modules\glob\node_modules\graceful-fs\fs.js:11:1)

QQ图片20171010102619

这个问题是升级了nodejs后导致的;

相关依赖报错,解决方法是升级相关依赖  graceful-fs 的版本:

可以看下当前的依赖;

npm list graceful-fs

解决办法:就删了node_modules重装,记得清除npm的缓存;

npm cache clean -f

删除后再install一次;

QQ图片20171010102852

再不行就慢慢查是哪个依赖的问题了,或者依赖都给升级了;

如果再不行,应该就是回滚NODE版本了把,6.0以及以后的版本,gulp有些不能用,另外建议,

nodejs使用稳定版本,

nodejs使用稳定版本,

nodejs使用稳定版本;

如果还不行,

引申:如果您是gulp的压缩不能用了,请移步这里 https://zhubangbang.com/gulp3-x-version-gulpuglifyerror-failed-to-shrink-javascript.html

~~~~

未经允许不得转载:朱邦邦的博客 » nodejs升级导致gulp不能用了

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址